Sony® Reader (PRS-500) Compatibility With Microsoft® Windows Vista® and Windows® 7 Operating Systems

Posted: 2/09/2007


Required Updates

Using the PRS-500 with EPUB format files, the Windows 7 operating system, or 64-bit versions of the Windows Vista operating system requires firmware version 2.0.

You will also need to download and install the latest version of the Reader™ Library software for the Reader device by Sony.

Alternate Update Method for Reader Library

  1. Within the Reader Library or eBook Library software, click the "Help" menu command.
  2. At the "Help" menu, click "Check for Updates".
  3. Click OK to download the update.